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Altiris eXpress™ Inventory Solution is designed to meet the demands of today's diverse network

environments. It gathers comprehensive software and hardware data from virtually any system

running a Windows 32-bit Operating System. A variety of deployment and data collection options

ensure that Inventory Solution works in any environment (including native integration for Microsoft Systems Management Server (SMS)). To help maximize your investment, Inventory Solution goes beyond simple data gathering. By providing a Web-based management console, Notification Policies to alert you of critical information, and professional quality Web Reports, Inventory Solution includes the tools you need to transform your inventory data into useful information.

Features and Benefits
• Works with computers with no IP connectivity. A floppy disk method has been designed for

these non-networked Windows workstations. See “Running Inventory Solution Using a Floppy

Disk” on page 54.

• Works with Non-SMS clients. Windows workstations that are not SMS clients can be

inventoried into Notification Server and integrated into the SMS database.

• Provides full access to all the data from any browser. Data can be accessed through Web Reports on Notification Server or through Web Administrator for Microsoft SMS using data that has been forwarded to the SMS database.

• Includes integrated Web Reports. Inventory Solution comes with numerous built-in reports that

help you analyze and make proactive management decisions based upon Inventory Solution data. This allows quick and easy access to inventory information without having to create custom SQL scripts. Custom reports may also be added and scheduled to run automatically.

• Posts data through files and HTTP. Inventory Solution data can be sent to Notification Server

through a file placed in the nscap\evtinbox folder or through an HTTP post to aexns/

postevent.asp.

• Deploys through e-mail, URL, login scripts. Inventory Solution can be deployed through e-mail,

a URL, login scripts, or any other method you have in place to run a program on the target

systems.

Inventory Solution data includes

• PC Serial Number and BIOS details

• Comprehensive software auditing

• Disk, operating system, and system configuration settings

• Registry settings

• Full end user information (with Microsoft Exchange profiles)

• WMI objects

Inventory Solution data can be posted to Notification Server by creating a file on a network share, by posting the data directly using HTTP, or it can submit the data to the NS Client process and let the NS Client post the data to the server.

Ease of Use and Deployment

A special emphasis has been placed on ease of deployment, small agent size, and non-intrusive

operation (by using unused CPU and network resources). Inventory Solution can be deployed to a client computer in multiple ways. The method you should use depends upon your particular needs. The deployment methods are:

• Logon Script

• SMS package

• E-mail (as a link or attachment)

• Web link

• Floppy disk

• Manual (through shared or mapped drive)

• NS Client

Inventory Scan Agents

Inventory Solution includes several inventory scan agents that determine what data will be collected in the inventory scan. The inventory scan agents can be found in the AeXInvSoln.ini file. The default AeXInvSoln.ini file is shown below:

aexauditpls.exe /hidden /output xml

aexmachinv.exe

aexcustinv.exe /in .\AeXCustInvStd.cit /out AeXCustInvStd.nsi

aexexchpls.exe /hidden /output xml

aexsnplus.exe /output xml

aexnsinvcollector.exe /hidden /o ..\..\..\EvtInbox

Software Scan (aexauditpls.exe) – Runs a detailed scan of the software installed on the computer. It uses the auditpls.ini file to control how applications are reported. There are several

powerful and flexible configuration options available in setting up your auditpls.ini file. For

more information, see “Software Audit Agent” on page 67.

Hardware Scan (aexmachinv.exe) – This is the hardware scanning agent for Inventory Solution. It reports data such as the operating system, the logged on user, the set of local and network disks, the amount of physical memory, the TCP/IP configuration, CPU, and PCMCIA devices. For more information, see “Machine Inventory Agent” on page 100.

Custom Scan (aexcustinv.exe) – This agent gathers data from the registry, WMI, or INI files using scripts to let you customize the set of data reported. For more information, see “Custom Inventory Agent” on page 85.

Exchange User Data Scan (aexexchpls.exe) – Reports data about the logged on user as found in the Microsoft Exchange Directory Service. For more information, see “Exchange Agent” on page 96.

Serial Number Scan (aexsnpls.exe) – Gathers serial number, computer make and model, BIOS, and memory module information. For more information, see “Serial Number Agent” on page 99.

Inventory Collector (aexnsinvcollector.exe) – Collects and consolidates all the data that each scan agent found during the scan. The scan data is consolidated and sent to Notification Server. For more information, see “Customizing How Data is Reported to Notification Server” on page 48.

SMS Integration

Inventory Solution is fully compatible with SMS 2.0. Inventory Solution is tightly integrated with Systems Management Server. Inventory Solution comes with Package Definition Files that make it a very simple process to deploy the Inventory Solution package as an SMS package.

Inventory agents report data to SMS using the industry standard MIF file format. SMS maintains

history information on changes that are reported by the Inventory agent. This lets you see what has changed over time on your computers. Inventory Solution lets you track in the SMS database computers that are not SMS clients. The agents AeXSNPlus, AeXAuditpls, and AeXExchpls can create a MIF on the SMS client’s NOIDMIF directory or XML data can be passed to the Notification Server and SMS data forwarding can create a native SMS MIF.

See “Using SMS to Deploy and Collect Inventory Solution Data” on page 56.

Installing and Setting Up Inventory Solution

Inventory Solution 5.5 is designed to work with Notification Server 5.5 or later. It is recommended that you install the latest service pack of Notification Server 5.5. Notification Server must be installed before installing Inventory Solution.

For more information on installing Notification Server, see “Notification Server Requirements” in

the Altiris eXpress Notification Server User Guide.

The following Windows Clients are supported by Inventory Solution

• Windows 32-bit systems

• Windows 95

• Windows 98

• Windows Me

• Windows NT 4

• Windows 2000

• Windows XP

Inventory Solution Prerequisite

• Microsoft Internet Explorer 4.01 or later - This installs DLL files needed by Inventory Solution.

Run Inventory Solution with NS Clients

When Inventory Solution is installed, it automatically gets sent to all NS Clients that the Notification Server communicates with. This happens through the Inventory Client policies.

To view the Inventory Client policies

1 From the Web Administration Console, select the Solutions tab.

2 In the left pane, select Inventory Solution > Policies > Inventory Client.

These policies are enabled by default, so they will be sent to the NS Clients on a schedule when

Inventory Solution is installed. For information on these policies, see “Policies” on page 31.

Manually Scan Inventory using AeXInvSoln.exe

1 On the target computer, run AeXInvSoln.exe from the install path\Altiris\eXpress

\Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server computer.

An inventory scan is initiated based on the default AeXInvSoln.ini file. The Inventory Scan

program closes automatically when the scan has completed.

To View Inventory Scan Results

View the results of your inventory scan in the Web Administration Console using the Resource

Explorer.

1 In the Web Administration Console, click the Solutions tab.

2 In the left pane, select Altiris eXpress Configuration > Collections > Standard Collections > All

Machines. (Click Yes if a security warning appears.)

3 Double-click the name of the computer on which you ran the manual scan. This opens an Altiris eXpress Resource Explorer window in a separate browser.

4 In the Resource Explorer, click the Summary and Inventory tabs to view data from your scan.

Run Inventory Solution using HTTP 

(without the NS Client Installed)

1 E-mail the following URL to the target set of computers and instruct the users to either download the file and then install it on their local computers or select “Open this file from its current location” to install the file without downloading it:

http://NSName/AeXNS/NSCAP/Bin/Win32/X86/AeXWebInvPkg.exe

where NSName is the name of your Notification Server. For more information on the Web Inventory Package (AeXWebInvPkg.exe), see “Web Inventory Package” on page 50.
Run Inventory Solution using a Network File Share (without the NS Client Installed)

You have two choices for running Inventory Solution using a Network File Share.

1 Use the Notification Server computer nscap share.

a Make sure that the users of your target computers have access to the following nscap share

   on the Notification Server: install path\Altiris\eXpress\Notification Server\NSCap

b Have the users of the target computers run the self extracting NSCap\Bin\Win32\X86

   \Inventory Solution\AeXWebInvPkg.exe file from the Notification Server computer.

2 Use another file server.

a Copy the self extracting AeXWebInvPkg.exe file to another file server (another Windows

   NT server in another LAN or domain, NetWare, UNIX, and so forth) that the target

   computers can connect to and have the users of the target computers run the self extracting

   AeXWebInvPkg.exe file from this server.

Note The self extracting AeXWebInvPkg.exe file is found in the install path\Altiris

\eXpress\Notification Server\NSCap\Bin\Win32\X86\Inventory Solution directory.

For more information on the Web Inventory Package (AeXWebInvPkg.exe), see “Web

Inventory Package” on page 50.

Perform a Software Scan

To perform a complete inventory scan, including a software scan

1 On the target computer, run AeXInvSoln.exe from the install path\Altiris\eXpress

   \Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server

   computer.

An inventory scan is initiated based on the default AeXInvSoln.ini file. The Inventory Scan

program closes automatically when the scan has completed.

To perform only a software scan

1 On the target computer, run AeXAuditPls.exe from the install path\Altiris\eXpress

   \Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server

   computer.

To perform a hidden software scan with XML output

1 Run the following from the Command Prompt.

   aexauditpls.exe /hidden /output xml

To edit the auditpls.ini file

1 Run AeXAPedit.exe from the install path\Altiris\eXpress\Notification

   Server\NSCap\Bin\Win32\X86 folder on the Notification Server computer.

2 Click File > Open.

3 Select the auditpls.ini file, then click Open.

See Also

• “Software Audit Agent” on page 67

• “AeXAuditpls” on page 112

• “Edit the AuditPls.ini file” on page 27

Perform a Hardware Scan

To perform a complete inventory scan, including a hardware scan

1 On the target computer, run AeXInvSoln.exe from the install path\Altiris\eXpress

\Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server

computer. An inventory scan is initiated based on the default AeXInvSoln.ini file. The Inventory Scan program closes automatically when the scan has completed.

To perform only a hardware scan

1 On the target computer, run AeXMachInv.exe from the install path\Altiris\eXpress

\Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server computer.

See Also

• “Machine Inventory Agent” on page 100

• “AeXMachInv” on page 116
Edit the AuditPls.ini file

This section shows you how to use the Audit Plus Configuration Editor to modify the

AuditPls.ini file. It shows you how to add specific programs that can be included in the

software scan.

Note The following should be completed from the server (install path\Program Files

\Altiris\eXpress\Notification Server\NSCap\Bin\Win32\X86).

1 In the X86 folder, make a backup copy of the AuditPls.ini file and place it on your desktop

for safekeeping.

2 In the X86 folder, double-click on the AeXAPedit.exe file. The Audit Plus Configuration Editor opens.

3 In the Audit Plus Configuration Editor, select File > Open and open the AuditPls.ini file

(from the x86 folder).

4 Under the Extensions tab, enter dll in the Extension field and click Add.

5 Under the Disk Usage tab, enter zip in the Extension field and click Add.

6 Under the Special Groups tab, click Add.

7 In the New Special Group dialog, enter AeX SW ACME in the Name field.

8 Enter ACME|Engineering|1.0 in the Class field.

9 Make sure Filename is selected in the Attribute field and add the following three attribute values:

   a Enter sol.exe and click Add.

   b Enter freecell.exe and click Add.

   c Enter winmine.exe and click Add.

10 In the Attribute field, select Internal Name and add the following three attribute values:

   a Enter sol.exe and click Add.

   b Enter freecell and click Add.

   c Enter winmine and click Add.

11 Click OK.

12 Under the Known As tab, enter sol.exe in the Internal name field and Solitaire in the Known as field, and click Add.

13 Repeat step 12 for winmine (Minesweeper) and freecell (Freecell).

14 Under the Overrides tab, click Add to open the Override Properties dialog box.

15 Under the A file with this property... column, enter sol.exe in the Filename field.

16 Under the ...is to be overridden with this property column, enter Solitaire in the Product name

field.

17 Click OK.

18 Repeat step 14 through step 17 for Freecell and Minesweeper.

19 In the Audit Plus Configuration Editor click File > Save to save changes to the AuditPls.ini

file.

20 Close the Audit Plus Configuration Editor.

21 Test the new auditpls.ini file by manually running the AexInvSoln.exe in the x86

   directory to be sure that it picks up the file you desire and reports it into inventory. You can tell

   it works because the inventory under this server explorer drilldown will have that change in it.

22 Copy the new auditpls.ini file in the x86 directory to the distribution directory. The

   auditpls.ini file that gets distributed with the inventory policies is located in install

   path\Program Files\Altiris\Express\Notification Server\nscap

   \bin\win32\x86\Inventory Solution.

23 Update the distribution point. To do this, open the Web Administration Console and navigate

   to Solutions > Inventory Solution > Packages > Inventory Client > Inventory Client. In the right 

   pane, click the Update Distribution Point button. This will force Notification Server to verify the   

   contents of the Inventory package.

24 In the X86 directory on the Notification Server computer, double-click the AeXInvSoln.exe

   file to run a new inventory scan. When your NS Client requests a new configuration, it will    

   realize that something in the package has changed and download your new auditpls.ini file and    

   run with that.

See Also

• “View Inventory Scan Results” below

View Inventory Scan Results

This section tells you how to view modified inventory results that are generated by changes to the AuditPls.ini configuration file.

Note The changes listed here were discussed in “Edit the AuditPls.ini file” on page 27. (Adding

Freecell, Solitaire, and Minesweeper programs and EXE, DLL, and ZIP extensions to get inventory

for.)

1 In the Web Administration Console, click the Solutions tab.

2 In the left column, select Altiris eXpress Configuration > Collections > Standard Collections > All

Machines.

3 Under the All Machines heading, double-click the name of the computer on which you ran the

scan. This opens (or refreshes a currently open) Resource Explorer window in a separate browser.

4 In the Resource Explorer, click the Inventory tab.

5 In the left column, click AeX SW ACME and verify that Freecell, Solitaire, and Minesweeper are

listed.

Note If the computer on which you run the scan does not have the Freecell, Solitaire, or

Minesweeper game installed, the AeX SW ACME table will not appear.

6 In the left column, click AeX SW Audit Software and verify that the list contains both EXE and DLL

files. (You will need to scroll all the way to the right to view extensions in the list.)

7 In the left column, click AeX SW Disk Usage and verify that ZIP files are included in the list.
Run Inventory Solution with a Zero Footprint

1 On the target computer, run the following from the install path\Altiris\eXpress

\Notification Server\NSCap\Bin\Win32\X86 folder on the Notification Server computer:

AeXInvSoln /zfp

An inventory scan is initiated based on the default AeXInvSoln.ini file. The /zfp switch

removes any NSI files that are created from the local computer after the scan. It also removes the GUID from the registry. The Inventory Scan program closes automatically when the scan has completed.

Note You can also use the Web Inventory Package, which by default runs an inventory with zero

footprint. See “Web Inventory Package” on page 50.

Logon Script Client Deployment

Inventory Solution can readily be deployed to clients through the use of logon scripts.

The file logonscript.bat is included in the install path\Altiris\eXpress

\Notification Server\NSCap\Bin\Win32\x86 folder when you install the win32inv.msi file on your Notification Server.

Frequency of Scan

Typically, you will want to limit the frequency at which the scan is run on a system. The following

logon script (logonscript.bat) will limit the scan to run no more frequently than once a week

(168 hours)

@Echo off

Rem - This is a sample logon script batch file that will run the

Rem - Inventory Solution client

Rem - every 7 days. The AeXRunControl.exe file limits the

Rem - frequency at which the called program

Rem - will be executed.

Rem - The parameters are AeXRunControl <key> <Number of Hours>

Rem - <Command Line>

Rem - <Key> is an arbitrary name for a key that will be created

Rem - in the registry that maintains

Rem - the history of when the command was last run. The Key is

Rem - created under Rem - HKLM\Software\Altiris\Run Control.

Rem - <Number of Hours> limits the frequency at which the command

Rem - line will be executed.

Rem - <Command Line> is the program to be run. The path is

Rem - relative to the location from where

Rem - AeXRunControl is executed.

AeXRunControl InvSoln 168 aexinvsoln.exe

The program AeXRunControl.exe is included in Inventory Solution (see “AeXRunControl” on

page 118). Adjust the Number of Hours parameter to adjust the maximum frequency at which

AeXInvSoln will be executed.

Note To use AeXInvSoln.exe command line parameters with AeXRunControl.exe, you

must place the command line in quotes. For example:

AeXRunControl InvSoln 168 “aexinvsoln.exe /hidden”

Necessary Files

If you want to run Inventory Solution from your logon server share point (netlogon) instead of the nscap share on your Notification Server, copy the Inventory Solution files to the logon server(s). These files are found in the install path\Altiris\eXpress\Notification Server

\NSCap\Bin\Win32\x86\Inventory Solution directory.

Example 1:
AeXNSInvCollector /v MYSERVER

Sends the Inventory Solution data to the location \myserver\nscap\evtinbox as a file. The

user must be able to connect to Notification Server and create a file in this directory.

Example 2:

AeXNSInvCollector /url http://myserver/AeXNS/postevent.asp
Sends the data to Notification Server through HTTP. No security context of the user is required as

this is an anonymous HTTP post.

NOTES:

